Posts by Jens_w

    In HHG ist die erste Spalte "XTSQL", während in XTC die erste Spalte "XTSOL" ist.
    Aber auch eine entsprechende Anpassung bringt keine Lösung.
    Darüber hinaus unterscheidet sich in den Export Dateien die Reihenfolge einiger Spalten.
    Interessant ist auch, dass beim Import ein neuer Hersteller angelegt wird. Herstellername ist dabei der Langtext der Artikelbeschreibung.
    Also so richtig glücklich macht mich das Ganze nicht.
    Betrifft dieses Problem nur mich?
    Wie haben andee Shops Ihre Importfunktion gelöst?
    Oder gibt es dieses Problem erst seit Ver. 3.2.962?
    Gibt es denn eine Möglichkeit das Multiimportmodul unabhängig von der EE-Version zu erwerben?

    Guter Hinweis, aber auch das hat nicht geholfen.
    Irgendwie scheint es aber ein Problem mit dem Im- und Exportmodul zu sein.
    Noch nicht einmal eine exportierte Testdatei mit einen Artikel wird beim Import richtig verarbeitet.
    So erscheint bei der Bezeichnung die Kategoriennummer und dementsprechend auch alle anderen Felder werden verschoben.
    Die Einstellungen habe ich mehrfach überprüft und auch mit unterschiedlichen Trennzeichen gab es keine Lösung.
    Bitte ggf. Beitrag verschieben, da dieses Problem nicht mehr unmittelbar mit dem Importscript "alter XTCShop" zu tun hat, aber auf Deine letzte Antwort Bezug nimmt.

    Habe ich mich doch etwas zu früh gefreut?
    Die Bilderzuordnung habe ich jetzt erst einmal zurück gestellt.
    Mein Problem ist noch der Datenimport des 2. Shops.
    Ich habe also als erstes den 2. Shop angelegt und anschließend das Script dahingehend verändert, dass ich alle in Frage kommenden Informationen auf die Shop-Nr. 2 abgeändert habe.
    Die Artikel und Kategorien wurden zwar importiert, aber die Artikel ließen sich nicht bearbeiten (Kein Editorfeld) bzw. die Kategorien wurden nicht auf der Startseite angezeigt (Erst nach Eingabe eines Suchbegriffs waren die neuen Kategorien mit Unterkategorien und Artikel da).
    Also habe ich wieder alles rückgängig gemacht und die Kategorien manuell angelegt. Anschließend wollte ich die Artikel per csv-Import einlesen.
    Aber auch das hat nicht geklappt. (vorher natürlich die Import-Datei entsprechend angepasst, Trennzeichen ; und Texttrenner " ) Es wurde aber nur 1 Datensatz importiert und dieser noch falsch. In der Artikelbezeichnung stand nur die Artikelnummer des letzten Artikels. Auch bei entsprechenden Variationen der Trennzeichen brachte keine Änderung.

    Danke für den Hinweis!
    Du hattest auch recht mit dem time out.
    Nachdem ich das Script Schritt für Schritt abgearbeitet habe sind nun endlich alle Kunden und Artikel drin.
    Leider werden die Artikelbilder noch nicht angezeigt. Die Bilder habe ich in den richtigen Verzeichnissen angelegt.
    Da ich aber in der Vergangenheit viele Artikelbilder mittels CAO hochgeladen habe, vermute ich da Differenzen mit den Dateinamen. In diesem Fall wird wohl nichts anderes bleiben, als alle Artikelbilder neu hochzuladen. ;(

    Hallo,
    Ich bin gerade dabei, meine beiden XTC-Shops auf H.H.G.-Multistore umzustellen und diese anschließend an CAO anzubinden.
    Aber bekanntermaßen sollte man dabei Schritt für Schritt vorgehen.
    Als erstes habe ich das Konvertierungstool laufen lassen und nach den entsprechenden Änderungen und Anpassungen bin ich auch schon recht weit gekommen.
    Mein Problem ist jetzt, dass dieses Script nicht bis zum Ende durchläuft und mit der Meldung:
    Starting customers conversion
    ohne Fehlermeldung abbricht. (der debug-Modus ist eingeschaltet) Es werden in der Tabelle customers ca. 1800 von ca. 3200 Kundendatensätze eingetragen, aber ansonsten nichts weiter.
    Das heißt, das Adressbuch und auch die Anzeige in der Kundenverwaltung ist trotz der angelegten Datensätze nicht vorhanden.
    (Meine Erfahrungen bei der Installation würde ich gerne in die Wiki einfließen lassen, aber ich bin ja noch nicht fertig)
    Vielen Dank im Voraus für entsprechende Hinweise