Probleme beim speichern der Artikelbeschreibung

  • Hallo,


    wen ich mit oder ohne Editor die Artikelbeschreibung speichere werden die " mit einem Slash \ versehen.
    Das heißt nach dem dritten mal speichern sieht es dann sio aus \\\"100%\\\".


    Es grüßt freundlich


    temoc25

  • Müssen wir mal überprüfen, wird am neuen Escaping liegen.

  • "rk_" schrieb:


    Das Problem liegt in den aktivierten magic_quotes von php, somit wird alles doppelt escaped.


    Datei /core/inc/inc.hhg_db_prepare.php mit der aus dem Anhang überschreiben (für alle fälle Alte Datei sichern.) Dies sollte das Problem lösen.


    Super Problem bei mir gelöst.

  • Ist in den Paketen bereits enthalten, das letzte Update gab am 11.02.2008

  • Habs aus dem alten Forum wieder als Anhang beim Post von rk_ hochgeladen.

  • Hhallo Hasan,


    funktioniert bei mir leider nicht.


    Aus

    PHP
    1. <div id="details">Test</div>

    wird

    PHP
    1. <div id="\&quot;details\&quot;">Test</div>

    nach dem Abspeichern. Nach jedem Speichern werden es mehr "\&quot;"


    Gruß, Thomas

  • Wie sahs mit der Original

    Zitat

    inc.hhg_db_prepare.php

    aus?

  • Müssen wir überprüfen

  • Versuch mal das hier:

    Zitat

    .htaccess


    folgendes einfügen:

    PHP
    1. php_flag magic_quotes_gpc off


    Mal sehen ob wir die magic_quotes ausgeschaltet bekommen... :whistling:

  • Zitat

    admin/core/functions/compatibility.php


    Zeile: 41ff

    PHP
    1. if (!get_magic_quotes_gpc()) {
    2. do_magic_quotes_gpc($_GET);
    3. do_magic_quotes_gpc($_POST);
    4. do_magic_quotes_gpc($_COOKIE);
    5. }


    ändern in:

    PHP
    1. /*if (!get_magic_quotes_gpc()) {
    2. do_magic_quotes_gpc($_GET);
    3. do_magic_quotes_gpc($_POST);
    4. do_magic_quotes_gpc($_COOKIE);
    5. }*/
  • kein Problem =)