Fehler bei Konfiguration -> Lieferstatus

  • Fehlermeldung bei Konfiguration und dann click auf Liferstatus.


    Fehler in der log:




  • Guck mal bitte in der Datenbank mittels phpMyAdmin in die Tabelle

    SQL
    1. ms_admin

    ob bei der

    SQL
    1. customers_id

    1 in

    SQL
    1. admin_group_id

    eine 1 steht.


    Habe den Verdacht das beide Fehler ( fehler bei produktgruppen ) das gleiche Problem sind.

  • das ist alles was in dieser Tabelle drin ist:




    Zitat


    customers_id admin_group_id


    1 1


    2 1



    also bei der customers_id 1 ist bei der admin_group_id eine 1 drin.


    und bei der customers_id 2 ist bei der admin_group_id auch eine 1 drin

  • Kannst Du das reproduzieren, wenn Du Dich neu anmeldest und in Admin gehst?

  • Habs gefunden :whistling:

    Zitat

    admin/core/modules/shipping_status.php


    Zeile: 30

    PHP
    1. $as = new msAdminStore;


    löschen


    Zeile: 74

    PHP
    1. $owner_array = $as->getChildStores($_SESSION['actual_store'], true);


    ändern in:

    PHP
    1. $owner_array = $store->getChildStores($_SESSION['actual_store'], true);
  • so das funktioniert jetzt.


    Aber wenn ich dann die Lieferstati aufgelistet habe und einen Status bearbeiten will kommt wieder die graue...



  • Zitat

    admin/core/classes/class.hhg_shipping_status.php


    Zeile: 156ff

    PHP
    1. if ($shipping_status_group !== false && $shipping_status_group != "") {
    2. $as = new msAdminStore;
    3. $owner_array = $as->getChildStores($_SESSION['actual_store'], true);


    ändern in:

    PHP
    1. global $store;
    2. if ($shipping_status_group !== false && $shipping_status_group != "") {
    3. $owner_array = $store->getChildStores($_SESSION['actual_store'], true);
  • Habe das Geändert, aber funktioniert immer noch nicht.


    Fehlermeldung:



  • Sind noch paar andere Änderungen nötig, nimm mal die ausm Anhang und lade diese nach

    Zitat

    admin/core/classes/

    hoch.
    Hast wohl eine Kombination verwendet, die bisher noch keiner in der Form eingesetzt hat, das es jetzt aufgefallen ist, kriegen wir aber auch noch hin. Im Release der R2 sollte es dann vollständig behoben sein.